After Tampermonkey updates, suddenly I cannot get @match to work for any of my custom userscripts anymore?

Script exchange and development requests
Post Reply
stabbyktn
Posts: 1
Joined: 16.07.17 21:06:35

After Tampermonkey updates, suddenly I cannot get @match to work for any of my custom userscripts anymore?

Post by stabbyktn » 16.07.17 21:10:43

Anyone know why this is happening? Tampermonkey will update the extension, and then suddenly all my custom userscripts stop working, and cannot get @match to work in the simplest userscripts anymore, despite they were working fine for a long time after I wrote them.

My userscripts dont even show up in the popup dialog which allows you to turn certain scripts on/off, which means @match was somehow broken in the last few updates or something.


Why is "@match *://www.tvguide.com/listings/*" not matching "http://www.tvguide.com/listings/" now even though it worked fine for a long time when I initially wrote my script? I can't get it to work at all now.

User avatar
derjanb
Site Admin
Posts: 2228
Joined: 20.01.06 02:16:15
Contact:

Re: After Tampermonkey updates, suddenly I cannot get @match to work for any of my custom userscripts anymore?

Post by derjanb » 17.07.17 14:21:47

This script is working fine here at http://www.tvguide.com/listings/

Code: Select all

// ==UserScript==
// @name         New Userscript
// @namespace    http://tampermonkey.net/
// @version      0.1
// @description  try to take over the world!
// @author       You
// @match        *://www.tvguide.com/listings/*
// @grant        none
// ==/UserScript==

console.log('foo');
ImageIf you like what I'm doing, please consider a donation here. Image

Post Reply

Return to “Userscripts”

Who is online

Users browsing this forum: No registered users and 1 guest